Remove automake 1.12 and 1.13.

automake 1.15 needs autoconf 2.69, which needs automake 1.11 but
we can skip intermediate versions.

Fixes: #93
Fixes: #100
master
Andrius Štikonas 2 years ago
parent 3dfe3dc0f0
commit 6e2f42c6a4
  1. 2
      SHA256SUMS.sources
  2. 10
      parts.rst
  3. 6
      sysa.py
  4. 23
      sysa/automake-1.12.6/automake-1.12.6.sh
  5. 16
      sysa/automake-1.12.6/patches/aclocal_glob.patch
  6. 23
      sysa/automake-1.13.4/automake-1.13.4.sh
  7. 16
      sysa/automake-1.13.4/patches/aclocal_glob.patch
  8. 4
      sysa/run2.sh

@ -11,8 +11,6 @@ db11944057f3faf229ff5d6ce3fcd819f565455c152b72cec17ebc1cbb80136b autoconf-2.65.
64ebcec9f8ac5b2487125a86a7760d2591ac9e1d3dbd59489633f9de62a57684 autoconf-2.69.tar.xz
e98ab43bb839c31696a4202e5b6ff388b391659ef2387cf9365019fad17e1adc automake-1.10.3.tar.bz2
4f46d1f9380c8a3506280750f630e9fc915cb1a435b724be56b499d016368718 automake-1.11.2.tar.bz2
f834ab2145b1ee24bd85387950044f5cb418dd0af2b84c52e60c2bf29162dbfa automake-1.12.6.tar.xz
89ce4933f59b8f0c20115c39cfe450a595cca74ede27b6881e88ec27720d1d66 automake-1.13.4.tar.xz
af6ba39142220687c500f79b4aa2f181d9b24e4f8d8ec497cea4ba26c64bedaf automake-1.15.1.tar.xz
503cdc2b0992a4309545d17f462cb15f99bb57b7161dfc4082b2e7188f2bcc0f automake-1.4-p6.tar.gz
0dbafacaf21e135cab35d357a14bdcd981d2f2d00e1387801be8091a31b7bb81 automake-1.6.3.tar.bz2

@ -585,16 +585,6 @@ autoconf 2.69
This the final version of GNU Autoconf that we will require. There are some newer
versions but we won't need them.
automake 1.12.6
===============
GNU Automake from 1.12 series.
automake 1.13.4
===============
GNU Automake from 1.13 series.
automake 1.15.1
===============

@ -423,12 +423,6 @@ class SysA:
# autoconf 2.69
self.get_file("https://mirrors.kernel.org/gnu/autoconf/autoconf-2.69.tar.xz")
# automake 1.12.6
self.get_file("https://mirrors.kernel.org/gnu/automake/automake-1.12.6.tar.xz")
# automake 1.13.4
self.get_file("https://mirrors.kernel.org/gnu/automake/automake-1.13.4.tar.xz")
# automake 1.15.1
self.get_file("https://mirrors.kernel.org/gnu/automake/automake-1.15.1.tar.xz")

@ -1,23 +0,0 @@
# SPDX-FileCopyrightText: 2021 Andrius Štikonas <andrius@stikonas.eu>
#
# SPDX-License-Identifier: GPL-3.0-or-later
src_prepare() {
default_src_prepare
autoreconf-2.69 -f
rm doc/automake-history.info
}
src_configure() {
./configure --prefix=/after
}
src_compile() {
make MAKEINFO=true CC=tcc
}
src_install() {
make install MAKEINFO=true DESTDIR="${DESTDIR}"
}

@ -1,16 +0,0 @@
SPDX-FileCopyrightText: 2021 Andrius Štikonas <andrius@stikonas.eu>
SPDX-License-Identifier: GPL-2.0-or-later
Fixes aclocal to work with our Perl
--- aclocal.in 2021-03-31 18:19:50.665806225 +0100
+++ aclocal.in 2021-03-31 18:20:02.836132739 +0100
@@ -42,6 +42,7 @@
use Automake::XFile;
use Automake::FileUtils;
use File::Basename;
+use File::Glob;
use File::Path ();
# Some globals.

@ -1,23 +0,0 @@
# SPDX-FileCopyrightText: 2021 Andrius Štikonas <andrius@stikonas.eu>
#
# SPDX-License-Identifier: GPL-3.0-or-later
src_prepare() {
default_src_prepare
autoreconf-2.69 -f
rm doc/automake-history.info
}
src_configure() {
./configure --prefix=/after
}
src_compile() {
make MAKEINFO=true CC=tcc
}
src_install() {
make install MAKEINFO=true DESTDIR="${DESTDIR}"
}

@ -1,16 +0,0 @@
SPDX-FileCopyrightText: 2021 Andrius Štikonas <andrius@stikonas.eu>
SPDX-License-Identifier: GPL-2.0-or-later
Fixes aclocal to work with our Perl
--- aclocal.in 2021-03-31 18:19:50.665806225 +0100
+++ aclocal.in 2021-03-31 18:20:02.836132739 +0100
@@ -42,6 +42,7 @@
use Automake::XFile;
use Automake::FileUtils;
use File::Basename;
+use File::Glob;
use File::Path ();
# Some globals.

@ -16,10 +16,6 @@ build automake-1.11.2
build autoconf-2.69
build automake-1.12.6
build automake-1.13.4
build automake-1.15.1
build tar-1.34

Loading…
Cancel
Save