You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

69 lines
1.8 KiB

# SPDX-FileCopyrightText: 2021 fosslinux <fosslinux@aussies.space>
# SPDX-FileCopyrightText: 2021 Andrius Štikonas <andrius@stikonas.eu>
#
# SPDX-License-Identifier: GPL-3.0-or-later
pylint_task:
container:
image: debian:bullseye
deps_script:
- apt-get -y update
- apt-get -y dist-upgrade
- apt-get -y install python3-requests pylint
- apt-get -y clean
check_script:
- pylint rootfs.py sysa.py lib/utils.py
shell_lint_task:
container:
image: debian:stable
deps_script:
- apt-get -y update
- apt-get -y dist-upgrade
- apt-get -y install shellcheck
- apt-get -y clean
check_script:
- shellcheck sysa/run.sh sysa/helpers.sh
reuse_lint_task:
container:
image: debian:stable
deps_script:
- apt-get -y update
- apt-get -y dist-upgrade
- apt-get -y install python3-pip git
- apt-get -y clean
- pip3 install reuse
check_script:
- reuse lint
run_task:
timeout_in: 180m
container:
image: potyarkin/molecule:host-kvm
kvm: true
cpu: 2
memory: 4G
# Required background services
dbus_background_script:
- mkdir -p /var/run/dbus
- /usr/bin/dbus-daemon --system --nofork --nopidfile
virtlogd_background_script:
- /usr/sbin/virtlogd
libvirtd_background_script:
- sleep 2 && /usr/sbin/libvirtd
iptables_legacy_script:
- update-alternatives --set iptables /usr/sbin/iptables-legacy
deps_script:
- apt-get -y update
- apt-get -y dist-upgrade
- apt-get -y install sudo git cpio linux-image-4.19.0-16-amd64 expect wget
- apt-get -y clean
submodule_script:
- git submodule update --init --recursive
kernel_script:
- cp /boot/vmlinuz-4.19.0-16-amd64 ./kernel
run_script:
- ./.cirrus.expect | tee -a /tmp/run.log
- grep -q 'Bootstrapping completed.' /tmp/run.log